Android OS 2.3: How can I get the updated version of the app?

Unfortunately the new release of SbS is not compatible with OS devices below 4.0

The new version is just too powerful behind the scenes to work properly on older OS’s. It would be PAINFULLY slow for you.

When you upgrade your phone, you’ll be able to access the new version. Until then, you can still use the original version in your Google Play store:

Still need help? Contact Us Contact Us